const regex = /^(?:\d{1,3}\.?\b){4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{1,3}\\.?\\b){4}$', 'gm')
const str = `127.0.0.1
192.168.1.1
192.168.0.1
1.2.3.4
0.0.0.0
400.30.20.1
001.02.3.40`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}