// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d{1,3}\.?\b){4}$").unwrap();
let string = "127.0.0.1
192.168.1.1
192.168.0.1
1.2.3.4
0.0.0.0
400.30.20.1
001.02.3.40";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}