$re = '/^(?:\d{1,3}\.?\b){4}$/m';
$str = '127.0.0.1
192.168.1.1
192.168.0.1
1.2.3.4
0.0.0.0
400.30.20.1
001.02.3.40';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);