#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]$|^[a-zA-Z][a-zA-Z.\-']{0,78}[a-zA-Z']$"
Local $sString = "abc.'" & @CRLF & _
"abc-'.'" & @CRLF & _
"ab-.''-a" & @CRLF & _
"rish a" & @CRLF & _
"rish.-" & @CRLF & _
"" & @CRLF & _
"a" & @CRLF & _
"a-" & @CRLF & _
"a-'" & @CRLF & _
"abc" & @CRLF & _
"-" & @CRLF & _
"'" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")