$re = '/^[a-zA-Z]$|^[a-zA-Z][a-zA-Z.\-\']{0,78}[a-zA-Z\']$/m';
$str = 'abc.\'
abc-\'.\'
ab-.\'\'-a
rish a
rish.-
a
a-
a-\'
abc
-
\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);