#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:[+-]?\d+\.?\d*[ ,]+){5}[+-]?\d+\.?\d*)|(?:(?:[+-]?\d+\.?\d*[ ,]+){2}[+-]?\d+\.?\d*)"
Local $sString = "textbefore 101, 520, 62" & @CRLF & _
"GOTO 960.93 796.22 59.20 -0.34 0.00 -89.81" & @CRLF & _
"$5GOTO 1960.93 1796.22 159.20 -0.34 0.00 -89.81" & @CRLF & _
"501, 513, 162" & @CRLF & _
"1040, 1040, 520 text after " & @CRLF & _
"error" & @CRLF & _
"222, 222" & @CRLF & _
"1500, 1500, 60 (1)" & @CRLF & _
"1337 1337 65" & @CRLF & _
"124.5, 133.6, 35.4" & @CRLF & _
"15:13:26 Condition: index_ != StringList::npos [line 178](125, 157, 215) " & @CRLF & _
"Allocating shadow map cache 6324 x 6324: 76.28 MB"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")