# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:[+-]?\d+\.?\d*[ ,]+){5}[+-]?\d+\.?\d*)|(?:(?:[+-]?\d+\.?\d*[ ,]+){2}[+-]?\d+\.?\d*)"
test_str = ("textbefore 101, 520, 62\n"
"GOTO 960.93 796.22 59.20 -0.34 0.00 -89.81\n"
"$5GOTO 1960.93 1796.22 159.20 -0.34 0.00 -89.81\n"
"501, 513, 162\n"
"1040, 1040, 520 text after \n"
"error\n"
"222, 222\n"
"1500, 1500, 60 (1)\n"
"1337 1337 65\n"
"124.5, 133.6, 35.4\n"
"15:13:26 Condition: index_ != StringList::npos [line 178](125, 157, 215) \n"
"Allocating shadow map cache 6324 x 6324: 76.28 MB")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.