const regex = /(?:(?:[+-]?\d+\.?\d*[ ,]+){5}[+-]?\d+\.?\d*)|(?:(?:[+-]?\d+\.?\d*[ ,]+){2}[+-]?\d+\.?\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:[+-]?\\d+\\.?\\d*[ ,]+){5}[+-]?\\d+\\.?\\d*)|(?:(?:[+-]?\\d+\\.?\\d*[ ,]+){2}[+-]?\\d+\\.?\\d*)', 'gm')
const str = `textbefore 101, 520, 62
GOTO 960.93 796.22 59.20 -0.34 0.00 -89.81
\$5GOTO 1960.93 1796.22 159.20 -0.34 0.00 -89.81
501, 513, 162
1040, 1040, 520 text after
error
222, 222
1500, 1500, 60 (1)
1337 1337 65
124.5, 133.6, 35.4
15:13:26 Condition: index_ != StringList::npos [line 178](125, 157, 215)
Allocating shadow map cache 6324 x 6324: 76.28 MB`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}