using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\S+)";
string input = @"elefante blanco
tonayan vs wackardÃ
pizza pizza pie
zzz anc
hshd household 8/29/2007 LB";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}