re = /(^\S+)/m
str = 'elefante blanco
tonayan vs wackardÃ
pizza pizza pie
zzz anc
hshd household 8/29/2007 LB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end