package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\S+)`)
var str = `elefante blanco
tonayan vs wackardÃ
pizza pizza pie
zzz anc
hshd household 8/29/2007 LB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}