re = /^.*\s(\p{L}*,.*$)/
str = 'Romin Romo Rosario, Salvedra Jimenez
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result