import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[(\\[-?\\d+(?:\\.\\d+)?,-?\\d+(?:\\.\\d+)?\\])(?:,\\[-?\\d+(?:\\.\\d+)?,-?\\d+(?:\\.\\d+)?\\])+,\\1\\]";
final String string = "[[106.00,-50.00],[109.00,-34.00],[101.00,-29.00],[105.00,-26.00],[116.00,-30.00],[114.00,-50.00]]\n"
+ "[[106.00,-50.00],[109.00,-34.00],[101.00,-29.00],[105.00,-26.00],[116.00,-30.00],[106.00,-50.00]]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}