use strict;
my $str = '[[106.00,-50.00],[109.00,-34.00],[101.00,-29.00],[105.00,-26.00],[116.00,-30.00],[114.00,-50.00]]
[[106.00,-50.00],[109.00,-34.00],[101.00,-29.00],[105.00,-26.00],[116.00,-30.00],[106.00,-50.00]]';
my $regex = qr/^\[(\[-?\d+(?:\.\d+)?,-?\d+(?:\.\d+)?\])(?:,\[-?\d+(?:\.\d+)?,-?\d+(?:\.\d+)?\])+,\1\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}