const regex = /^\[(\[-?\d+(?:\.\d+)?,-?\d+(?:\.\d+)?\])(?:,\[-?\d+(?:\.\d+)?,-?\d+(?:\.\d+)?\])+,\1\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[(\\[-?\\d+(?:\\.\\d+)?,-?\\d+(?:\\.\\d+)?\\])(?:,\\[-?\\d+(?:\\.\\d+)?,-?\\d+(?:\\.\\d+)?\\])+,\\1\\]', 'gm')
const str = `[[106.00,-50.00],[109.00,-34.00],[101.00,-29.00],[105.00,-26.00],[116.00,-30.00],[114.00,-50.00]]
[[106.00,-50.00],[109.00,-34.00],[101.00,-29.00],[105.00,-26.00],[116.00,-30.00],[106.00,-50.00]]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}