#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bF150\b.*"
Local $sString = "G1 X277.8072 Y212.6482 Z-2.5000" & @CRLF & _
"G1 X277.3935 Y212.6617 Z-2.5000" & @CRLF & _
"G1 X276.9809 Y212.6737 Z-2.5000" & @CRLF & _
"G1 F150 Z-4.0000" & @CRLF & _
"G1 X276.9809 Y212.6738 Z-4.0000" & @CRLF & _
"G1 X276.5705 Y212.6846 Z-4.0000 "
Local $sSubst = "$0\nG1 F1000"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)