use strict;
my $str = 'G1 X277.8072 Y212.6482 Z-2.5000
G1 X277.3935 Y212.6617 Z-2.5000
G1 X276.9809 Y212.6737 Z-2.5000
G1 F150 Z-4.0000
G1 X276.9809 Y212.6738 Z-4.0000
G1 X276.5705 Y212.6846 Z-4.0000 ';
my $regex = qr/\bF150\b.*/mp;
my $subst = '$0\\nG1 F1000';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";