import Foundation
let pattern = #"\bF150\b.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
G1 X277.8072 Y212.6482 Z-2.5000
G1 X277.3935 Y212.6617 Z-2.5000
G1 X276.9809 Y212.6737 Z-2.5000
G1 F150 Z-4.0000
G1 X276.9809 Y212.6738 Z-4.0000
G1 X276.5705 Y212.6846 Z-4.0000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0\nG1 F1000"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)