package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*(\d|[1-9]\d+)(\s+(\d|[1-9]\d+)){2}(\s+((0x(\d|[a-f]|[A-F}]){1,8})|[1-9]\d+|\d))*\s*$`)
var str = `10 10 0 0x1 34243`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}