$re = '/^\s*(\d|[1-9]\d+)(\s+(\d|[1-9]\d+)){2}(\s+((0x(\d|[a-f]|[A-F}]){1,8})|[1-9]\d+|\d))*\s*$/';
$str = '10 10 0 0x1 34243';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);