import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(\\d|[1-9]\\d+)(\\s+(\\d|[1-9]\\d+)){2}(\\s+((0x(\\d|[a-f]|[A-F\\}]){1,8})|[1-9]\\d+|\\d))*\\s*$";
final String string = "10 10 0 0x1 34243";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}