import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/www\\.roblox\\.com\\/games\\/\\d{1,}\\/?[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)*$";
final String string = "https://www.roblox.com/games/12345678/GameName";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}