re = /^https:\/\/www\.roblox\.com\/games\/\d{1,}\/?[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)*$/
str = 'https://www.roblox.com/games/12345678/GameName'
# Print the match result
str.match(re) do |match|
puts match.to_s
end