use strict;
my $str = 'Goodbye bye bye world world world
';
my $regex = qr/\b(\w+)\b\s*(?=.*\b\1\b)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";