$re = '/\b(\w+)\b\s*(?=.*\b\1\b)/m';
$str = 'Goodbye bye bye world world world
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;