re = /\b(\w+)\b\s*(?=.*\b\1\b)/m
str = 'Goodbye bye bye world world world
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result