$re = '/\d{8}/m';
$str = 'This is some text in the e-mail and the following is the number you were looking for: 12345678 - are you satisfied?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);