re = /\d{8}/m
str = 'This is some text in the e-mail and the following is the number you were looking for: 12345678 - are you satisfied?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end