import re
regex = re.compile(r"\d{8}", flags=re.MULTILINE)
test_str = "This is some text in the e-mail and the following is the number you were looking for: 12345678 - are you satisfied?"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")