using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(test|foo|bar\/baz(?!\/?\?)|en|ppp)(\/[-\w?=]+)*\/?";
string input = @"www.mysite.com/bar/baz/?uid=100/
www.mysite.com/bar/baz?uid=100
www.mysite.com/bar/baz
www.mysite.com/bar/baz/en/?uid=100
www.mysite.com/bar/baz/en/?uid=100/
www.mysite.com/en/bar/baz/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}