re = /\/(test|foo|bar\/baz(?!\/?\?)|en|ppp)(\/[-\w?=]+)*\/?/m
str = 'www.mysite.com/bar/baz/?uid=100/
www.mysite.com/bar/baz?uid=100
www.mysite.com/bar/baz
www.mysite.com/bar/baz/en/?uid=100
www.mysite.com/bar/baz/en/?uid=100/
www.mysite.com/en/bar/baz/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end