import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/(test|foo|bar\\/baz(?!\\/?\\?)|en|ppp)(\\/[-\\w?=]+)*\\/?";
final String string = "www.mysite.com/bar/baz/?uid=100/\n"
+ "www.mysite.com/bar/baz?uid=100\n"
+ "www.mysite.com/bar/baz\n"
+ "www.mysite.com/bar/baz/en/?uid=100\n"
+ "www.mysite.com/bar/baz/en/?uid=100/\n"
+ "www.mysite.com/en/bar/baz/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}