const regex = /\/(test|foo|en|ppp|bar\/baz)(\/?((?<!bar\/baz\/?)\?\w+=\w+|[-\w]+))*\/?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(test|foo|en|ppp|bar\\\/baz)(\\\/?((?<!bar\\\/baz\\\/?)\\?\\w+=\\w+|[-\\w]+))*\\\/?$', 'gm')
const str = `www.mysite.com/bar/baz/?uid=100/
www.mysite.com/bar/baz?uid=100
www.mysite.com/bar/baz
www.mysite.com/bar/baz/en/?uid=100
www.mysite.com/bar/baz/en/?uid=100/
www.mysite.com/en/bar/baz/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}