const regex = new RegExp('^(\\d+(?:\\.\\d*?[1-9](?=0|\\b))?)\\.?0*$', 'gm')
const str = `11.00000
12.30000
12.00000
1.234000
1.012345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}