$re = '/^(\d+(?:\.\d*?[1-9](?=0|\b))?)\.?0*$/m';
$str = '11.00000
12.30000
12.00000
1.234000
1.012345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);