re = /^(\d+(?:\.\d*?[1-9](?=0|\b))?)\.?0*$/m
str = '11.00000
12.30000
12.00000
1.234000
1.012345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end