$re = '/\b(?:\w*?[aeiou]{2}){2}\w*\b/';
$str = 'that contain 2 or more 2 letter sequences of vowels (e.g. visionproof, steamier, preequip).';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);