re = /\b(?:\w*?[aeiou]{2}){2}\w*\b/
str = 'that contain 2 or more 2 letter sequences of vowels (e.g. visionproof, steamier, preequip).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end