using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?://\S+?/blah/|\G(?!^))(?:%2C)?\K\d+";
string input = @"https://test.example.com/blah/12345%2C80%2C8263473%2C9475834343";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}