const regex = new RegExp('(?:https?://\\S+?/blah/|\\G(?!^))(?:%2C)?\\K\\d+', 'gm')
const str = `https://test.example.com/blah/12345%2C80%2C8263473%2C9475834343`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}