re = /(?:https?:\/\/\S+?\/blah\/|\G(?!^))(?:%2C)?\K\d+/m
str = 'https://test.example.com/blah/12345%2C80%2C8263473%2C9475834343'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end