import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\-{0,1})(?:(?:0*)(\\d+))?((?:\\.)(?:\\d*?))?0*$";
final String string = "-0.002506000\n"
+ "1\n"
+ "01\n"
+ "10\n"
+ "1.25\n"
+ "01.250\n"
+ "0\n"
+ "0002345000\n"
+ "0.25\n"
+ "0.50\n"
+ "0.5\n"
+ "0.75000\n"
+ "1000\n"
+ "0001.111\n"
+ "0001.5\n"
+ ".25\n"
+ "01234\n"
+ "-00.1\n"
+ ".2500\n"
+ ".0256\n"
+ "-.010";
final String subst = "$1$2$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}