import Foundation
let pattern = #"^(\-{0,1})(?:(?:0*)(\d+))?((?:\.)(?:\d*?))?0*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-0.002506000
1
01
10
1.25
01.250
0
0002345000
0.25
0.50
0.5
0.75000
1000
0001.111
0001.5
.25
01234
-00.1
.2500
.0256
-.010
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)