#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)\bcontact:*\s*([^,.\s]+)"
Local $sString = "ntpd process is not running on lnx31 contact: app-support. @monitoringautomation" & @CRLF & _
"" & @CRLF & _
"ntpd process is not running on lnx31 contact: app-support, @monitoringautomation" & @CRLF & _
"" & @CRLF & _
"ntpd process is not running on lnx31 contact app-support @monitoringautomation"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")