re = /(?i)\bcontact:*\s*([^,.\s]+)/m
str = 'ntpd process is not running on lnx31 contact: app-support. @monitoringautomation
ntpd process is not running on lnx31 contact: app-support, @monitoringautomation
ntpd process is not running on lnx31 contact app-support @monitoringautomation'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end