import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\bcontact:*\\s*([^,.\\s]+)";
final String string = "ntpd process is not running on lnx31 contact: app-support. @monitoringautomation\n\n"
+ "ntpd process is not running on lnx31 contact: app-support, @monitoringautomation\n\n"
+ "ntpd process is not running on lnx31 contact app-support @monitoringautomation";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}