using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^:\n]*):([^:\n]*):([^:\n]*):([^:\n]*):([^:\n]*):([^:\n]*):([^:\n]*):([^:\n]*):([^:\n]*)$";
string input = @"value1:value2:value3:value4:value5::value7:value8:
value1:value2:value3:value4::value6:value7::value9";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}