$re = '/^([^:\n]*):([^:\n]*):([^:\n]*):([^:\n]*):([^:\n]*):([^:\n]*):([^:\n]*):([^:\n]*):([^:\n]*)$/m';
$str = 'value1:value2:value3:value4:value5::value7:value8:
value1:value2:value3:value4::value6:value7::value9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);