import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^:\\n]*):([^:\\n]*):([^:\\n]*):([^:\\n]*):([^:\\n]*):([^:\\n]*):([^:\\n]*):([^:\\n]*):([^:\\n]*)$";
final String string = "value1:value2:value3:value4:value5::value7:value8:\n"
+ "value1:value2:value3:value4::value6:value7::value9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}