using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"T40[0-9][0-9][.][a-zA-Z]+";
string input = @"T4018.test.12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}